No ETA is available at this time, though Idaho Falls Fiber continues to work on the fiber cut.
Identified
Identified
A major fiber cut, likely caused by a tractor, has resulted in an outage. Technicians need to complete over 500 splices and will be working overnight. Service is expected to be restored by tomorrow morning.
Investigating
Investigating
An outage has been reported in the Idaho Falls IDF008 zone, and their team has been alerted to respond.