sumofiber - Utopia Outage in Orem, Utah (OR027) – Incident details
Get updates
Email
SMS
Webhook
RSS
Atom
Get updates
Dark mode
All systems operational
Utopia Outage in Orem, Utah (OR027)
Resolved
Partial outage
0
Started 5 days ago
Lasted about 11 hours
Affected
Utopia Fiber
Operational from 2:45 PM to 1:48 AM
Orem
Operational from 2:45 PM to 1:48 AM
Updates
Resolved
June 21, 2025 at 1:48 AM
Resolved
June 21, 2025 at 1:48 AM
This incident has been resolved.
Investigating
June 20, 2025 at 2:45 PM
Investigating
June 20, 2025 at 2:45 PM
UTOPIA Network Outage Notification - DESCRIPTION: UTOPIA has been alerted to an outage in the (OR027) footprint(s) in Orem, Utah. Field Services are in transit to the site.