Scheduled for March 28, 2025 at 7:00 AM – 11:00 AM
Affects
Denver
Under maintenance from 7:00 AM to 11:00 AM
Completed
March 28, 2025 at 11:00 AMCompleted
March 28, 2025 at 11:00 AMMaintenance has completed successfully
In progress
March 28, 2025 at 7:00 AMIn progress
March 28, 2025 at 7:00 AMMaintenance is now in progress
Planned
March 28, 2025 at 7:00 AMPlanned
March 28, 2025 at 7:00 AMthe underlying network is upgrading the OS on the switch we are connected to. this will cause a 30 minute outage for all customers in Colorado Springs.