Scheduled for April 24, 2024 at 5:59 AM – 10:59 AM
Affects
Providence City
Under maintenance from 5:59 AM to 10:59 AM
Lehi City Fiber
Under maintenance from 5:59 AM to 10:59 AM
Updates
Completed
April 24, 2024 at 10:59 AM
Completed
April 24, 2024 at 10:59 AM
The scheduled maintenance has been completed.
In progress
April 24, 2024 at 5:59 AM
In progress
April 24, 2024 at 5:59 AM
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Update
April 24, 2024 at 4:59 AM
Planned
April 24, 2024 at 4:59 AM
Maintenance will begin as scheduled in 60 minutes.
Planned
April 15, 2024 at 2:59 PM
Planned
April 15, 2024 at 2:59 PM
We would like to inform you that StrataFl and/or one of our partners will be conducting scheduled maintenance as described below. During this time, you will experience brief service disruptions. We apologize for any inconvenience this may cause and assure you that the technicians will work diligently to restore services as quickly as possible.
Date of Outage: April 23, 2024
Start Time: 2359 PM MST
End Time: 0459 AM MST
Reason for Maintenance:
Upgrade firmware to ensure continued stability and security.