sumofiber - Utopia Outage Logan Fiber Cut – Incident details

All systems operational

Utopia Outage Logan Fiber Cut

Resolved
Partial outage 5 %
Started about 2 months agoLasted about 16 hours

Affected

Utopia Fiber

Partial outage from 2:42 AM to 6:48 PM

Logan

Partial outage from 2:42 AM to 6:48 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Fiber cut has been confirmed.  Crews have been dispatched to repair damage.  Current ETR is 12:00 a.m. 

  • Investigating
    Investigating

    Multiple customers down in the LG001 area off of different devices. Possible fiber damage.