Utopia Maintenance: Murray, Utah (MU023) - Power - Device/Replacement
Completed
Scheduled for February 20, 2026 at 7:01 AM – 1:00 PM
Affects
Utopia Fiber
Under maintenance from 7:01 AM to 1:00 PM
Murray
Under maintenance from 7:01 AM to 1:00 PM
Updates
Completed
February 20, 2026 at 1:00 PM
Completed
February 20, 2026 at 1:00 PM
Maintenance has completed successfully
In progress
February 20, 2026 at 7:01 AM
In progress
February 20, 2026 at 7:01 AM
Maintenance is now in progress
Planned
February 20, 2026 at 7:01 AM
Planned
February 20, 2026 at 7:01 AM
Utopia Maintenance Notification: MU004 UPS replacement 2/20/2026 12am-6am - CATEGORY: Power - Device/Replacement - MAINTENANCE START TIME: 2026-02-20 12:01:00AM - MAINTENANCE END TIME: 2026-02-20 06:00:00AM -- SCOPE OF IMPACT: Customers in the listed zones will experience a brief outage during maintenance.