sumofiber - Utopia Outage in Brigham City, Utah (BR004) – Incident details

Midvale experiencing partial outage

Utopia Outage in Brigham City, Utah (BR004)

Resolved
Partial outage
Started 5 days agoLasted about 2 hours

Affected

Utopia Fiber

Partial outage from 6:25 PM to 8:32 PM

Brigham City

Partial outage from 6:25 PM to 8:32 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    ADS device down. Field service on route.