Scheduled for October 10, 2025 at 7:30 PM – October 11, 2025 at 5:00 AM
Affects
Utopia Fiber
Under maintenance from 7:30 PM to 5:00 AM
Orem
Under maintenance from 7:30 PM to 5:00 AM
Updates
Completed
October 11, 2025 at 5:00 AM
Completed
October 11, 2025 at 5:00 AM
Maintenance is now in progress
In progress
October 10, 2025 at 7:30 PM
In progress
October 10, 2025 at 7:30 PM
Maintenance is now in progress
Planned
October 10, 2025 at 7:30 PM
Planned
October 10, 2025 at 7:30 PM
Utopia Maintenance Notification: Emergency fiber repair. OR014 - CATEGORY: Fiber - Repair/UndergroundCableDamage - MAINTENANCE START TIME: 2025-10-10 01:30:00PM - MAINTENANCE END TIME: 2025-10-10 11:00:00PM -- SCOPE OF IMPACT: Customers in the listed zones will experience a brief outage during maintenance.