sumofiber - Utopia Outage in Pleasant Grove, Utah (PG005) – Incident details
Get updates
Email
SMS
Webhook
RSS
Atom
Get updates
Dark mode
System Under Maintenance
Utopia Outage in Pleasant Grove, Utah (PG005)
Resolved
Partial outage
Started 4 months ago
Lasted 15 minutes
Affected
Utopia Fiber
Partial outage from 7:58 PM to 8:13 PM
Pleasant Grove
Partial outage from 7:58 PM to 8:13 PM
Updates
Resolved
March 31, 2025 at 8:13 PM
Resolved
March 31, 2025 at 8:13 PM
This incident has been resolved.
Investigating
March 31, 2025 at 7:58 PM
Investigating
March 31, 2025 at 7:58 PM
Device lost connection. FSG heading to site to identify issue.