Scheduled for August 30, 2024 at 6:00 AM – 12:00 PM
Affects
Utopia Fiber
Under maintenance from 6:00 AM to 12:00 PM
Clearfield
Under maintenance from 6:00 AM to 12:00 PM
Updates
Completed
August 30, 2024 at 12:00 PM
Completed
August 30, 2024 at 12:00 PM
Maintenance has completed successfully
In progress
August 30, 2024 at 6:00 AM
In progress
August 30, 2024 at 6:00 AM
Maintenance is now in progress
Planned
August 30, 2024 at 6:00 AM
Planned
August 30, 2024 at 6:00 AM
MAINTENANCE NOTIFICATION: CF006 - Clearfield
START: 8/30/2024 12:00 AM MST
STOP: 8/30/2024 6:00 AM MST
We have a planned maintenance tonight. All customers will experience a brief outage as we perform a power upgrade. ~569 residential customers will be affected.