sumofiber - Service Disruption: Idaho Falls Fiber Outage – Incident details

All systems operational

Service Disruption: Idaho Falls Fiber Outage

Resolved
Operational
Started 9 months agoLasted 25 minutes

Affected

Idaho Falls Fiber

Operational from 5:36 PM to 6:01 PM

Updates
  • Resolved
    Resolved

    Idaho Falls Fiber has informed us that the outage has been resolved. If you are still experiencing internet issues, please don't hesitate to give us a call.

  • Update
    Update

    We are continuing to investigate this issue.

  • Investigating
    Investigating

    Idaho Falls Fiber is currently investigating an outage impacting a significant number of customers in the Idaho Falls area. Idaho Falls Fiber is actively working to identify and resolve the issue. Updates will be provided as soon as more information becomes available. Thank you for your patience.