sumofiber - Fiber Outage in Lehi – Incident details

All systems operational

Fiber Outage in Lehi

Resolved
Partial outage
Started 3 months agoLasted about 8 hours

Affected

Lehi City Fiber

Operational from 7:21 PM to 7:21 PM, Partial outage from 7:21 PM to 3:45 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    Statafi has notified us of a fiber outage in Lehi. They are actively investigating the issue and will provide updates as soon as new information becomes available.