sumofiber - Utopia Outage in Brigham City, Utah (BR007,BR001,BR002) – Incident details
Get updates
Email
SMS
Webhook
RSS
Atom
Get updates
Dark mode
All systems operational
Utopia Outage in Brigham City, Utah (BR007,BR001,BR002)
Resolved
Partial outage
Started about 15 hours ago
Lasted about 3 hours
Affected
Utopia Fiber
Partial outage from 3:13 PM to 6:04 PM
Brigham City
Partial outage from 3:13 PM to 6:04 PM
Updates
Resolved
March 31, 2026 at 6:04 PM
Resolved
March 31, 2026 at 6:04 PM
This incident has been resolved.
Investigating
March 31, 2026 at 3:13 PM
Investigating
March 31, 2026 at 3:13 PM
Tripped breaker took down core router